プロジェクト

全般

プロフィール

IntelliJ IDEA Community Editionセットアップ

インストール

Windows へのインストール

インストーラーを実行するとインストールされます。デフォルトでは、C:\Program Files\JetBrains@IntelliJ IDEA Community Edition 2020.1 1 にインストールされます。

1 末尾の数字はIntelliJ IDEAのバージョン

install-1.png

次にインストールオプションを聞いてきます。

install-2.png

インストール後初回起動時は、IntelliJ IDEAの構成を設定する画面が出てきます。
まずは、UIテーマの選択です。

customize_intelliJ-1.png

  • 目に優しいダーク系であるDarculaを設定しました。

次は、有効にする機能の設定です。

customize_intelliJ-2.png

  • Build Tools は、Ant、Maven、Gradleの設定が可能で、デフォルトは全てが有効です。例えばMavenを使わないならチェックを外す等のカスタマイズができます。

customize_intelliJ-3.png

  • Version Controls は、CVS、Git、GitHub、Mercurial、Subversionの設定が可能で、デフォルトは全てが有効です。
  • Test Tools は、JUnit、TestNG-J、Coverageの設定が可能で、デフォルトは全てが有効です。
  • Swing はサブ画面はなく有効か無効かを切り替えます。
  • Android はサブ画面はなく有効か無効かを切り替えます。
  • Other Tools は、Bytecode Viewer、Eclipse、Java Stream Debugger、Task Management、Terminal、YAML、XSLT and XPath の設定が可能で、デフォルトは全てが有効です。
  • Plugin Development はサブ画面はなく有効か無効かを切り替えます。

次は、追加ダウンロードするプラグインの選択です。

customize_intelliJ-4.png

  • Scalaプラグイン、AWSツールキット、Eduツール、Key Promoter X、IDEトレーニング、Gradianto、File変更監視プラグインが選択可能です。

このあと、IntelliJ が起動します。インストール直後は前バージョンの設定を引き継いでいない場合、前回開いたプロジェクトがないので、プロジェクトの選択画面が出ます。

customize_intelliJ-5.png

プロジェクトを開くと、めでたく開発画面が表示されます。

intelliJ-01.png

日本語化

IntelliJ IDEA 2020.1から、公式の日本語リソース(Japanese Language Pack)が適用できるようになります。
従来のIntelliJ IDEAの日本語化に用いてきた Pleiadesプラグイン(AOPツール)は、2020.1以降では非推奨となります。

日本語リソース(2020.1以降)

Pluginから、Japanese Language Packを選択してインストールします。

Pleiades(2019まで)

Pleiades と呼ばれる、実行時に動的に処理を付加して日本語化するagentコードを使用すると日本語化することが可能です。

  • https://www.willbrains.jp/page/4#step
    ここから、Windows用のPleiadesプラグインをダウンロードします。ダウンロードしたzipを作業領域に展開し、その中にあるsetup.exe(setup\setup-pleiades.exeへのショートカット)を実行します。

pleiades-1.png

「Pleiades日本語化プラグインのセットアップ」画面が表示されます。[選択]ボタンを押し、「日本語化するアプリケーションの選択(exe)」画面が表示されるので、IntelliJ IDEAのインストール先ディレクトリにある実行ファイル(idea.exeとidea64.exeがあるのでどっちを指定するか悩みますが、64bit版OSなら後者と推測)を選択し[開く]ボタンを押します。

pleiades-2.png

[日本語化する]ボタンを押します。成功したら[終了]ボタンを押します。

IntelliJ IDEA を起動します。

pleiades-3.png

プロジェクトを開き主要画面を表示します。

pleiades-4.png

Git連携

IntelliJ IDEAは環境変数PATH上にあるgit.exeを使用しますが、SourceTree等の環境変数PATHにはgit.exeがないツールを使用している場合、git.exeのパスをIntelliJに設定する必要があります。

[File]メニュー > [Settings] > [Version Control] > [Git] を選択し、[Path to Git executable]欄の右端の[...]をクリックし、git.exeのファイルを指定します。

隠しフォルダ(例:AppData)はファイルツリーに表示されませんが、ファイル選択ダイアログのツールアイコンの右端にある[Show Hidden Files and Directories]をクリックすると隠しファイルが表示されるようになります。

  • SourceTreeのgit.exeの場所
    C:\Users\<ユーザー>\AppData\Local\Attlasian\SourceTree\git_local\bin\git.exe

アンインストール

Windows版のアンインストール

[スタート] > [設定] > [アプリ] で、アプリと機能の一覧から[IntelliJ IDEA Community Edition 2019.1.2] 1 を実行します。

1 名称の末尾の数字はインストールしたときのバージョンが表示

次にユーザー固有設定フォルダを削除します。

C:\Users\<ユーザー名>\.IdeaIC2019.3 2

2 名称の末尾の数字は使用していたバージョン

見栄え(Look and Feel)

フォント

エディタ以外の場所(メニュー、プロジェクトペイン等)に表示されるフォントは、デフォルトでは、 Java SE Development Kitのフォント設定 Windows OSの設定に従います。Windows 10日本語版では、Yu Gothic となっています。

エディタ部分のフォントは、デフォルトではJava SE Development Kitのフォント設定(Monospaced)となっています。OracleのJava SE Development Kitの日本語のフォントは、Windows上ではMonospacedにMS ゴシックが当てられています。

フォントの変更

[File]メニュー > [Settings]で「Settings」画面を開きます。

  • メニュー、プロジェクトビューなどのフォントを変更
    左側ペインで [Appearance & Behavior] > [Appearance]を選択し、右側ペインで[Override default fonts by (not recommended):]にチェックを付けてフォントを指定します。
  • エディタのフォントを変更
    左側ペイン [Editor] > [Font]で、右側ペインに設定します。
    フォントの設定では、プログラミングに向いた英字用等幅フォント(Consolasなど)を指定、フォールバック・フォントには日本語フォント(Meiryo)を指定するとよいかと思います。ただし、メイリオの日本語1文字の幅とConsolasの英字2文字の幅とが一致しないので、それが気になる場合は日本語等幅フォントを別途インストールします。(Myrica M等)

IntelliJでのフォント選択については、[フォントがぁ…]も参照(Myrica Mの設定も記載)。

ダークテーマ

デフォルトの色調は、背景が白で文字が黒という構成です。長時間作業するときには目が疲れにくい背景が暗い色の方が楽という意見もあります。
IntelliJ IDEA Community Editionでは、「カラースキーム」としてDefaultの他に背景が暗色のDarculaが用意されています。
[File]メニュー > [Settings] で「Settings」画面を表示し、左側ペインで[Editor] > [Color Scheme]を選択し、右側ペインでスキームを[Default]から[Darcula]に変更します。

キーバインド

Emacsキーバインドに慣れていると、コード編集がEmacsキーバインドでないと辛いです。幸いにもIntelliJ IDEAはEmacsキーバインド設定を選択できるので、設定を変更します。

[File]メニュー > [Settings]で「Settings」画面を表示し、左側ペインで[Keymap]を選択、右側ペインでキーマップ欄を[Default]から[Emacs]に変更します。

メモリ設定

IntelliJ IDEA自身が使用するメモリ設定は、デフォルトでは小さい値(ヒープ最大サイズが750MB)のため、使用しているうちにヒープ不足となることがあります。
[Help]メニュー > [Edit Custom VM Options] で、IntelliJ起動時のJVMオプションの設定を開き、値を修正することができます。

# custom IntelliJ IDEA VM options

-Xms128m
-Xmx750m
-XX:ReservedCodeCacheSize=240m
-XX:+UseConcMarkSweepGC
-XX:SoftRefLRUPolicyMSPerMB=50
-ea
-Dsun.io.useCanonCaches=false
-Djava.net.preferIPv4Stack=true
-Djdk.http.auth.tunneling.disabledSchemes="" 
-XX:+HeapDumpOnOutOfMemoryError
-XX:-OmitStackTraceInFastThrow

JDK

IntelliJ IDEA自身はJavaで作られたプログラムなので、IntelliJ IDEAを実行するのに必要なJavaランタイム環境(JRE:Java Runtime Environment)を一緒にインストールしています。しかし、IntelliJ IDEAで開発するプログラム(プロジェクト)には別途Java開発キット(JDK:Java Development Kit)を必要とします。これはIntelliJ IDEAには含まれないので、別途インストールしてIntelliJ IDEAから参照できるように設定をする必要があります。

使用する可能性のあるJDKの登録

[File]メニュー > [Other Settings] > [Structure for New Projects...] で「Project Structure for New Projects」画面を開き、左側ペインで[Platform Settings] > [SDKs]を選択します。初期状態では右側ペインが空です。

platform_sdk-1.png

中ペインの上の[+]アイコンをクリックし、[JDK]を選択します。

platform_sdk-2.png

「Select Home Directory for JDK」画面が開くので、使用する可能性のあるJDKのディレクトリを選択します。

platform_sdk-3.png

次の画面は、JDK-10を選択したときのものです。

platform_sdk-4.png

デフォルトのプロジェクト設定

[File]メニュー > [Other Settings] > [Structure for New Projects...] で「Project Structure for New Projects」画面を開き、左側ペインで[Project Settings] > [Project]を選択、右側ペインのプロジェクトSDK欄のドロップダウンリストを開き、先に設定したJDKの中からデフォルトのJDKを選択します。

project_sdk-1.png

最初にしておく設定

ファイル編集に関する設定

ファイル保存時にファイル末尾が改行で終わる

[File]メニュー > [Settings] で「Settings」画面を開き、左側ペインで[Editor] > [General] をドリルダウンして選択、右側ペインで[Save Files]グループの[Ensure an empty line at the end of a file on Save]にチェックを付けます。

POSIX規格ではテキストファイル中の行は、改行で終わることになっているため。

ファイルの改行コードを指定したい

Windows上でIntelliJ IDEAで作成したテキストファイルの改行コードは、デフォルトでCRLFとなります。
これを、IntelliJ IDEAで新たに作成したファイルの改行コードを指定したものとすることも可能です。

[File]メニュー > [Settings] で「Settings」画面を開き、左側ペインで[Editor] > [Code Style] をドリルダウンして選択、右側ペインで[General]タブを選択、[Line separator]欄をドロップダウンリストから[Unix and macOS (\n)]を選択します。

コードの品質保証

静的解析ツールの適用

Javaのソースコード品質を確保するための活動の一つとして、ソースコードを静的解析ツールで検査するものがあります。Javaでは、Checkstyle、PMD、FindBugsが広く使われています。

IntelliJ IDEAにこの静的解析ツールを導入するプラグインがいくつか提供されています。

QAPlugシリーズ

CheckStyle、PMD、FindBugsを使ってIntelliJ IDEAで開発しているJavaソースコード(バイトコード)を静的解析し問題点をレポートします。

手動で実施する方法と、リアルタイムで実施する方法が用意されています。

JavaFX

IntelliJ IDEAは、デフォルトでJavaFXプロジェクト生成を有しています。

[File]メニュー > [New] > [Project]で「New Project」画面を開き、左側ペインで[Java FX]を選択、右側ペインで唯一の[JavaFX Application]を選択し、[Next]をクリック
プロジェクト名、プロジェクト作成ディレクトリを指定します。

生成されるファイルは次の通りです。

 +- .idea
 +- src
     +- sample
     |   +- Controller.java
     |   +- Main.java
     |   +- sample.fxml
     +- JavaFxApplication.iml

パッケージ名、クラス名、FXMLファイル名をプロジェクト作成時には指定できないので、いったん生成してから変更することになります。
Controller.javaは空っぽです。
sample.fxmlは、GridPaneが記述されています。
Main.javaは、Applicationをextendsし、FXMLファイルをロードして表示する最低限の記述があります。